use strict;
my $str = '&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors';
my $regex = qr/[,](?![^(]*\))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";