re = /[,](?![^(]*\))/
str = '&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result