$re = '/[,](?![^(]*\))/';
$str = '&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;