$re = '/(\d.{0,}\.\d{0,})/';
$str = '========================================
1.123
1,000.0132
1,000,000.123
1 000.123
1 000 000.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);