package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d.{0,}\.\d{0,})`)
var str = `========================================
1.123
1,000.0132
1,000,000.123
1 000.123
1 000 000.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}