import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d.{0,}\\.\\d{0,})";
final String string = "========================================\n\n"
+ "1.123\n\n"
+ "1,000.0132\n\n"
+ "1,000,000.123\n\n"
+ "1 000.123\n\n"
+ "1 000 000.123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}