#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d.{0,}\.\d{0,})"
Local $sString = "========================================" & @CRLF & _
"" & @CRLF & _
"1.123" & @CRLF & _
"" & @CRLF & _
"1,000.0132" & @CRLF & _
"" & @CRLF & _
"1,000,000.123" & @CRLF & _
"" & @CRLF & _
"1 000.123" & @CRLF & _
"" & @CRLF & _
"1 000 000.123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")