using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d.{0,}\.\d{0,})";
string input = @"========================================
1.123
1,000.0132
1,000,000.123
1 000.123
1 000 000.123";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}