re = /(?<!^)((?:[A-Z](?=[a-z]))|(?:[A-Z]{2,}(?=[A-Z][a-z])))/m
str = 'HREdit
ITEdit
ImageEditHRStuffSomeMOREStuff
SecurityAdmin'
subst = ' $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result