# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!^)((?:[A-Z](?=[a-z]))|(?:[A-Z]{2,}(?=[A-Z][a-z])))/ $1/gm;t' <<< "HREdit
ITEdit
ImageEditHRStuffSomeMOREStuff
SecurityAdmin"