use strict;
my $str = 'HREdit
ITEdit
ImageEditHRStuffSomeMOREStuff
SecurityAdmin';
my $regex = qr/(?<!^)((?:[A-Z](?=[a-z]))|(?:[A-Z]{2,}(?=[A-Z][a-z])))/mp;
my $subst = ' $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";