const regex = /(?<!^)((?:[A-Z](?=[a-z]))|(?:[A-Z]{2,}(?=[A-Z][a-z])))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^)((?:[A-Z](?=[a-z]))|(?:[A-Z]{2,}(?=[A-Z][a-z])))', 'gm')
const str = `HREdit
ITEdit
ImageEditHRStuffSomeMOREStuff
SecurityAdmin`;
const subst = ` $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);