$re = '/(?<!^)((?:[A-Z](?=[a-z]))|(?:[A-Z]{2,}(?=[A-Z][a-z])))/m';
$str = 'HREdit
ITEdit
ImageEditHRStuffSomeMOREStuff
SecurityAdmin';
$subst = " $1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;