// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);").unwrap();
let string = "<word>523213042_OPIEKUNKI</word>
 Osób starszych,prca za granicą, Francuski, & Niemiecki & komunikatywnie ߬ certyfikat 3828";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}