const regex = /&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);', 'g')
const str = `<word>523213042_OPIEKUNKI</word>
 Osób starszych,prca za granicą, Francuski, & Niemiecki & komunikatywnie ߬ certyfikat 3828`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}