using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);";
string input = @"<word>523213042_OPIEKUNKI</word>
 Osób starszych,prca za granicą, Francuski, & Niemiecki & komunikatywnie ߬ certyfikat 3828";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}