$re = '/&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);/';
$str = '<word>523213042_OPIEKUNKI</word>
 Osób starszych,prca za granicą, Francuski, & Niemiecki & komunikatywnie ߬ certyfikat 3828';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);