re = /&(#(x[[:xdigit:]]+|[[:digit:]]+)|[[:alnum:]]+);/
str = '<word>523213042_OPIEKUNKI</word>
 Osób starszych,prca za granicą, Francuski, & Niemiecki & komunikatywnie ߬ certyfikat 3828'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end