// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+7\s\(\d{3,4}\)\s\d{2,3}\-\d{2}\-\d{3}").unwrap();
let string = "+7 (3452) 10-10-105
+7 (343) 100-10-105";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}