using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+7\s\(\d{3,4}\)\s\d{2,3}\-\d{2}\-\d{3}";
string input = @"+7 (3452) 10-10-105
+7 (343) 100-10-105";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}