import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+7\\s\\(\\d{3,4}\\)\\s\\d{2,3}\\-\\d{2}\\-\\d{3}";
final String string = "+7 (3452) 10-10-105\n"
+ "+7 (343) 100-10-105";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}