$re = '/\+7\s\(\d{3,4}\)\s\d{2,3}\-\d{2}\-\d{3}/m';
$str = '+7 (3452) 10-10-105
+7 (343) 100-10-105';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);