package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+7\s\(\d{3,4}\)\s\d{2,3}\-\d{2}\-\d{3}`)
var str = `+7 (3452) 10-10-105
+7 (343) 100-10-105`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}