import Foundation
let pattern = #"(?<=\s|\.|,|^)+[0-9]+(\.|,|\S)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"44. The fibers will stay in your hair overnight with only a minimal need for touch-ups in the morning. If you are using it every day, a 12g bottle of Toppik Hair Building Fibers will last about 30 days, and a 27.5g bottle will last about 60 days. 44. test [19459006] Repairs bare patches 60% faster St. Augustine Grass. It has an NPK ratio of 24-2-11"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)