re = /(?<=\s|\.|,|^)+[0-9]+(\.|,|\S)?/m
str = '44. The fibers will stay in your hair overnight with only a minimal need for touch-ups in the morning. If you are using it every day, a 12g bottle of Toppik Hair Building Fibers will last about 30 days, and a 27.5g bottle will last about 60 days. 44. test [19459006] Repairs bare patches 60% faster St. Augustine Grass. It has an NPK ratio of 24-2-11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end