using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|\.|,|^)+[0-9]+(\.|,|\S)?";
string input = @"44. The fibers will stay in your hair overnight with only a minimal need for touch-ups in the morning. If you are using it every day, a 12g bottle of Toppik Hair Building Fibers will last about 30 days, and a 27.5g bottle will last about 60 days. 44. test [19459006] Repairs bare patches 60% faster St. Augustine Grass. It has an NPK ratio of 24-2-11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}