import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s|\\.|,|^)+[0-9]+(\\.|,|\\S)?";
final String string = "44. The fibers will stay in your hair overnight with only a minimal need for touch-ups in the morning. If you are using it every day, a 12g bottle of Toppik Hair Building Fibers will last about 30 days, and a 27.5g bottle will last about 60 days. 44. test [19459006] Repairs bare patches 60% faster St. Augustine Grass. It has an NPK ratio of 24-2-11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}