# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\s|\.|,|^)+[0-9]+(\.|,|\S)?"
test_str = "44. The fibers will stay in your hair overnight with only a minimal need for touch-ups in the morning. If you are using it every day, a 12g bottle of Toppik Hair Building Fibers will last about 30 days, and a 27.5g bottle will last about 60 days. 44. test [19459006] Repairs bare patches 60% faster St. Augustine Grass. It has an NPK ratio of 24-2-11"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.