import Foundation
let pattern = #"(?:<.*?>|&\w++;)(*SKIP)(*F)|micro"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"micro"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"µ"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)