const regex = /(?:<.*?>|&\w++;)(*SKIP)(*F)|micro/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<.*?>|&\\w++;)(*SKIP)(*F)|micro', 'g')
const str = `micro`;
const subst = `µ`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);