$re = '/(?:<.*?>|&\w++;)(*SKIP)(*F)|micro/';
$str = 'micro';
$subst = "µ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;