package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:<.*?>|&\w++;)(*SKIP)(*F)|micro`)
var str = `micro`
var substitution = "µ"
fmt.Println(re.ReplaceAllString(str, substitution))
}