$re = '/^\s*<asi-page value="(\d+)" \/>/m';
$str = '<asi-page value="34" />';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;