using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*<asi-page value=""(\d+)"" \/>";
string substitution = @"$1";
string input = @"<asi-page value=""34"" />";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}