const regex = /^\s*<asi-page value="(\d+)" \/>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*<asi-page value="(\\d+)" \\\/>', 'gm')
const str = `<asi-page value="34" />`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);