use strict;
my $str = '<asi-page value="34" />';
my $regex = qr/^\s*<asi-page value="(\d+)" \/>/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";