# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*<asi-page value="(\d+)" \\/>/$1/gm;t' <<< "<asi-page value=\"34\" />"