// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\w*[@]\w+[.]\w{0,4}").unwrap();
let string = "harsh@gmail.com
rahultrivedi180@gmail.com
lol@.com
hello.com
@.com
rahultrivedi180@hotmail.com
glsica.org
glsica@gmail.com
rrhul_@yahoo.in";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}