$re = '/\w*[@]\w+[.]\w{0,4}/m';
$str = 'harsh@gmail.com
rahultrivedi180@gmail.com
lol@.com
hello.com
@.com
rahultrivedi180@hotmail.com
glsica.org
glsica@gmail.com
rrhul_@yahoo.in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);