import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w*[@]\\w+[.]\\w{0,4}";
final String string = "harsh@gmail.com\n"
+ "rahultrivedi180@gmail.com\n"
+ "lol@.com\n"
+ "hello.com\n"
+ "@.com\n"
+ "rahultrivedi180@hotmail.com\n"
+ "glsica.org\n"
+ "glsica@gmail.com\n"
+ "rrhul_@yahoo.in";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}