#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w*[@]\w+[.]\w{0,4}"
Local $sString = "harsh@gmail.com" & @CRLF & _
"rahultrivedi180@gmail.com" & @CRLF & _
"lol@.com" & @CRLF & _
"hello.com" & @CRLF & _
"@.com" & @CRLF & _
"rahultrivedi180@hotmail.com" & @CRLF & _
"glsica.org" & @CRLF & _
"glsica@gmail.com" & @CRLF & _
"rrhul_@yahoo.in"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")