const regex = /\w*[@]\w+[.]\w{0,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w*[@]\\w+[.]\\w{0,4}', 'gm')
const str = `harsh@gmail.com
rahultrivedi180@gmail.com
lol@.com
hello.com
@.com
rahultrivedi180@hotmail.com
glsica.org
glsica@gmail.com
rrhul_@yahoo.in`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}