import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"[^\p{Han}\p{Z}\p{M}\ta-zA-Z0-9]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}