# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\p{Han}\p{Z}\p{M}\ta-zA-Z0-9]"
test_str = "反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 "
matches = re.search(regex, test_str, re.UNICODE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.