import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\p{Han}\\p{Z}\\p{M}\\ta-zA-Z0-9]";
final String string = "反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}