const regex = new RegExp('[^\\p{Han}\\p{Z}\\p{M}\\ta-zA-Z0-9]', 'u')
const str = `反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}