use strict;
my $str = '反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 反反复复1234qwer00012121212121 反反复复1234qwer00012 1212121 21 ';
my $regex = qr~[^\p{Han}\p{Z}\p{M}\ta-zA-Z0-9]~up;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}