// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m){{\s*lang\(\"(.*?)\"(.*?)}}"#).unwrap();
let string = "<div class=\"col-12 col-md-8 offset-md-2 mb-2\">
<h5 class=\"text-danger\">
{{lang(\"SiteCadastro.alterarsenha.erromsg1\")|raw}}
<br><br>
{{lang(\"SiteCadastro.alterarsenha.erromsg2\")|raw}}
</h5>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}