const regex = /{{\s*lang\(\"(.*?)\"(.*?)}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{\\s*lang\\(\\"(.*?)\\"(.*?)}}', 'gm')
const str = `<div class="col-12 col-md-8 offset-md-2 mb-2">
<h5 class="text-danger">
{{lang("SiteCadastro.alterarsenha.erromsg1")|raw}}
<br><br>
{{lang("SiteCadastro.alterarsenha.erromsg2")|raw}}
</h5>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}