using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{\s*lang\(\""(.*?)\""(.*?)}}";
string input = @"<div class=""col-12 col-md-8 offset-md-2 mb-2"">
<h5 class=""text-danger"">
{{lang(""SiteCadastro.alterarsenha.erromsg1"")|raw}}
<br><br>
{{lang(""SiteCadastro.alterarsenha.erromsg2"")|raw}}
</h5>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}